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1. Getting started: Viewing subpictures 
 

1.1   Opening vob files. 

This is very easy. You can either drag/drop vob files, or use the File menu. 
DVDSubEdit will start scanning the file(s) for subpicture packs in the background. As 
more subpicture units (SPUs) are found, the display is updated but you can start 
looking at the subpics before the scanning is entirely done. 
 

• Full title set: To look at the subpictures for an entire video title set, select all 
the VOBs of the title domain (for example vts_01_1.vob vts_01_2.vob 
vts_01_3.vob) and drag/drop them on the DVDSubEdit window.  
 

 

Alternately you can use “Open full 
domain” in the File menu to open all the 
files belonging to the same domain as the 
selected file. For example, selecting 
vts_01_2.vob will open the entire first 
video titleset. 

 

• Single vob: You can look at only one of the vob file if you prefer (for example, 
dragging/dropping vts_01_2.vob) but it’s possible that the first subpicture unit 
will not be detected properly (because part of it is located in the previous vob 
file). You can also use “Open file” in the File menu. 
 

• Menus: You can also look at menus by dragging/dropping or opening a menu 
vob file, for example vts_01_0.vob or video_ts.vob. This will show you button 
highlights etc. However, because most button highlights are transparent by 
default (until a button is selected or activated), you probably will only see the 
background video and the button rectangles. To see the highlights, you can 
change the transparency using the transparency slider. 
 

• Fast Reload of last vob(s): You can also select “Fast reload last vob(s)” or use 
the Ctrl-O shortcut to reload the last vob (or set of vobs) you loaded. 



DVDSubEdit keeps a temporary file that includes all the information about spus 
for the last loaded files, so when this option is used the vob files do not need 
to be scanned and the operation is very quick. 
 

 

1.2    Selecting subtitles to visualize or modify. 

By default, DVDSubEdit shows you all the subpicture units that it finds. But you can 
filter them by stream ID (i.e., by language) or by the video cell (i.e., “chapter”) 
they belong to. To do that, use the stream and VCID drop down selectors.  
 

 

In this example, only the subpictures of 
stream 0x20 (which corresponds to the 
english subtitles according to the IFO 
files) are displayed, and only those that 
belong to the video cell 1/1 (i.e., with the 
VID 1 and CELLID 1). 

 
By clicking “Show Mod.” you can only show those subpictures that you have 
modified one way or another. If you haven’t modified any, no subpicture will be 
displayed. The other options are explained further down in this manual. 
Once you have selected which subpictures to look at, you can use the slider to 
quickly move through them or the arrow buttons to go from one to the next or 
previous one. 

 
 
Normally the background video is displayed along with the subtitles but you can 
disable that by unchecking “Show video frame”. This can be useful if the 
subpicture is difficult to see against a “busy” background. 
 

 

If you’re opening a menu vob 
and buttons are present, 
DVDSubEdit will display 
button rectangles as in this 
example. However, you 
probably won’t see any 
button highlight unless you 
modify the transparency 
using the transparency slider, 
because most button 
highlights are transparent by 
default, until a button is 
selected/activated. 

 



 

1.3   Understanding subtitle info 

Subpicture information is mainly displayed in the left part of the display: 
 

• In this example, we’re looking at subpicture 
pack (spu) number 3.  

• The stream ID is 0x20 (hexadecimal for 
stream 32).  

• LBA (logical block address) tells you where 
the first sector of the first subpicture pack is 
for this spu.  

• V/CID indicates which vob cell this spu 
belongs to, in this case vobid 1 and cellid 1.  

• The duration shows that the second set of 
commands (DCSQT) which holds the Stop 
command is delayed by 3.52 seconds. 

• The DCSQTs are the sets of commands for 
the spu. The first one has no delay, and 
comprises 6 commands: Set Color, Set 
Contrast, Set Display Area, Set Field Index, 
Start and End of commands.  

• The second DCSQT only has a stop 
command. 

 

 
In addition, the selection drop down list 
indicates the language of the subtitles 
(English in this example). Note that the 
language is defined in the IFO files, and it can 
change from PGC to PGC. For example, the 
stream ID 0x20 might be declared as an 
English subtitle in one PGC, then as another 
language in another PGC.  

 
 
 

1.4   The Color Lookup Table (CLUT) 

 
Subtitles colors are defined by the color lookup 
table (CLUT) used in the PGC in which the cell 
containing the subpicture pack is referenced. 
DVDSubEdit shows the 4 colors assigned to each 
pixel types (‘b’ for background, ‘p’ for pattern, 
‘e1’ for emphasis 1, and ‘e2’ for emphasis 2).  

 

The CLUT is read from the IFO file, and specifically from the first PGC that 
references the VCID cell the subpicture belongs to. Of course, this can change from 
cell to cell, so it’s possible to see the CLUT change when you move the subpicture 



selection slider. Checking “Ignore CLUT” can be useful if the CLUT defined in the 
IFO has four identical colors (in which case it’s impossible to see the various pixels 
types). When the option is checked, DVDSubEdit uses a default CLUT with very 
different colors for each pixel types. You can click on each tile to adjust the color 
of the default CLUT. The default colors are saved in a preference file. 
If the app shows “Now clut”, either the IFO file could not be found or opened, or 
the cell in which the subpicture belongs in not referenced in any of the PGCs. In 
such case, the default CLUT is used. Checking “Automatic CLUT” makes DVDSubEdit 
use white for “text” pixels and black for all others. Text pixels are the pixels used 
for the body of the subtitle characters, and are identified when the file is loaded. 
This option is very useful when you don’t have the IFO that corresponds to the VOB 
files, or when you’re loading a .sup file. 
 
 

1.5   Multiple sets of commands 

If your subpicture  data has multiple sets of commands 
(DCSQTs), you can select which one to visualize (and later 
modify) using the DSCQT drop-down selector. This will update 
the supicture display to reflect the commands and 
parameters used in the DCSQT. 

 

NOTE: DVDSubEdit currently only uses the first DCSQT to position the subpicture. In 
other words, if one of the subsequent DCSQT has commands to move the 
subpicture, these commands will not be reflected in the subpicture display. 
Similarly, if you move the subpicture, only the first DCSQT parameters will be 
modified.



 

2. Modifying subpictures 
 

2.1   General: modifying 1 or many subpictures 

Modifying an individual subpicture:  
When you move a slider to modify your subtitles, only the subpicture currently 
displayed is modified. All other ones are left alone. Typically, when you’re satisfied 
with your modifications, you can apply them to the rest of the subtitles by clicking 
the  “Apply to all selected” button . 
 
Modifying a group of subpictures:  
When you click “Apply to all selected”, all the currently selected subtitles are 
modified in the same way the currently visible one was modified.  
For example, if you have selected stream 0x20, belonging to VCID 1/3, only these 
subpictures will be modified. This makes it easy to modify only a given language (by 
selecting the appropriate stream) or a given chapter (by selecting the appropriate 
VCID). For example, to change the start command of all English subtitles, you would 
select the stream corresponding to the English language, then change the start 
command of one of the subtitles, then click the “Apply to all selected” button. 
A small pop-up dialog then appears where you can select which of the modifications 
you have made to the current subpicture you would like to apply to the rest of 
them. 
 

 
 
For example, if you’ve modified the start command and you’ve moved the subtitle, 
you can decide to only apply the change to the start command by only clicking that 
box.  
 
Copying changes to another subpicture:  



You can also modify the current subpicture then 
apply the same modifications to another subpicture 
by selecting “Apply last modifs” in the Edit menu 
(or using the Ctrl-V shortcut). Using the left and 
right keyboard arrows and the Ctrl-V shortcut is a 
good way to quickly modify a group of subtitles. 

 
 
Undoing changes: 
You can select “Reload this spu from file” in the Edit menu (or use the Ctrl-Z 
shortcut) to reload the currently viewed subpicture from the file, or “Reload all 
spus from file” to undo all your changes.  
 
Saving your changes: 
Once you’re satisfied with your modifications, you can select “Save all modifs” (or 
use the Ctrl-S shortcut) in the File menu to save all your changes back into the vob 
files. Note that there is no undo in that case! Once the changes are saved to the 
vob files, there is no way to go back to the originals, unless you have kept a copy of 
the files in another directory. 
 
 

2.2   Changing the transparency 

 
 
Changing the transparency of your subtitles can easily be done using the 
transparency slider. You must first chose which of the 4 pixel types you want this to 
be applied to.  
Choosing ‘b’, ‘p’, ‘e1’ or ‘e2’ will select the background, 
pattern, emphasis 1 or 2 pixels for modification. The slider 
will then only change the transparency of the selected 
pixels. 
You can choose “All pixels” to modify the transparency of all 
but the “true background” pixels. The background pixels are 
left alone so the background video can still be seen by 
transparency.  
 

 

This is useful to reveal subpictures that are initially transparent, such as button 
highlights in menus. DVDSubEdit tries to be smart about identifying truly 
background pixels: Assuming that the ‘b’ pixels are indeed used for the background 
is a bad idea as this is certainly not mandatory and in many cases, they’re not. 
DVDSubEdit assumes that the top left pixel in the subpicture is of the type used for 
the background. 
 



2.3   Hiding subpictures 

To hide subpictures you can click the “Hide subpic” button, 
which simply sets all transparencies to 0.  
 

 

 

2.4   Changing the colors 

Simply click on one of the tiles to select which color of 
the current CLUT will be used for a given pixel type. To 
adjust the “e1” pixel type, click on the e1 tile. 

 
A dialog will pop up, allowing you to chose the color 
among the 16 offered by the CLUT. For your convenience, 
the dialog indicates which LU (if looking at a menu vob) 
and which PGC the CLUT is defined in.  
NOTE: If you want to apply the color changes to the rest 
of the selected subpictures, you can apply the changes 
you made to all the pixels in one shot (unlike 
transparency, you do not have to apply to all after 
changing the color for each pixel). 

 
 
 

2.5   Modifying the “start” command 

A drop-down list is available to select the subpicture start 
command. Subtitles normally use a “Normal Start” 
command, in which case the subtitles are only displayed if 
the corresponding subtitle stream is selected and the 
subtitles are turned on in the player.  

 

A “Forced Start” command can be used instead, in which case the subtitles are 
displayed even if the subtitles are turned off in the player. Forced subtitles are 
often used when a character is speaking in a tongue that is foreign to the main 
language used in the movie, for example aliens in a sci-fi movie. 
Menu highlights always use a forced start command. 
 

2.6   Modifying the subtitle vertical positions by hand 

Use the slider or the entry box to move the 
subpicture by the desired number of pixels.  
  

Note that subpictures can only be moved by an even number of pixels. 



DVDSubEdit also limits the amount you can move subpictures so none of the 
“useful”pixels will disappear from the video frame. Once again, this applies to all 
but non “truly background” pixels (i.e. pixels that DVDSubEdit has determined are 
used as background). If you’re using borders (see below) DVDSubEdit makes sure 
none of the useful pixels disappear from inside the selected borders. 
 

2.7   Modifying the subtitle vertical positions using the borders 

It is often easier and faster to define borders in which you want your subtitles to 
fall. This can be done using the border slider and the border selector. 
 
Using the border slider: 
The border slider can be used to adjust bottom 
and top borders (shown in red in the video 
display) which define an area where subtitles 
will be confined. 

 
The currently viewed subtitle is moved up or down until it fits entirely inside the 
“safe” area defined by the two red lines. This can be very useful to automatically 
move all the subtitles within a given area of the screen: adjust the borders to the 
appropriate position, then click “Apply to All Selected” to apply the modification to 
all selected subtitltes. 
 
Using pre-selected borders: 
The drop-down list lets you pick from pre-selected borders: 

• 4:3 safe area cuts about 16% of the total image height (8% at the top and 8% 
at the bottom) to account for the television overscan. 

• 16:9 already letterboxed is useful for widescreen movies that are authored 
as 4:3 letterboxed DVDs (i.e. 4:3 movies with the top and bottom black 
bars). Selecting this ensure the subtitles fall within the actual widescreen 
video (and not in the black bars). This can be useful if you intend to zoom to 
get rid of the black bars during playback. 

• 16:9 already letterboxed safe adds a safe area to make sure your television 
overscan does not cut into the subtitles. 

 
NOTE: The border option is disabled if the subpicture corresponds to a menu 
(more specifically, if the VOBU the spu falls within has buttons). In addition, when 
you click “Apply to all selected”, subpics containing button highlights will not be 
moved. This prevents inadvertently moving button highlights in button-over-video 
situations (e.g. the rabbit in the matrix movies). 
 
 

2.8   Changing the subtitle horizontal position  

Use the slider to change the horizontal 
position of your subpics. This is only possible, 
however, if the subpicture background does 
not occupy the entire screen.  

 



If the slider is not enabled, your subpicture background is the size of the entire 
screen and DVDSubEdit cannot move the subpicture unless the background is 
cropped. This can be done by clicking the “Crop subpic background” button. 
DVDSubEdit then decode the subpicture data, crops the background to the minimum 
size that still encloses the useful part of the subpicture (the text), and then re-
encode the data. Once this is done, the slider is enabled. To crop all selected 
subpictures, simply press Ctrl-A (or select “Apply last modifs to all” in the Edit 
menu).  
 

 

2.9   Changing the subtitle duration 

Use the slider or the entry box to change the 
length of time during which the subpicture is 
displayed.   

The slider will only allow valid durations: for example, you cannot display a 
subpicture past the start time of the next subpicture (in the same stream). 
Similarly, you cannot set the duration to 0 (because two DCSQT normally can’t have 
the same delay value). 
The slider simply alters the delay value of the last DCSQT (which normally holds the 
“stop” command). You cannot change the delay of an individual DCSQT (yet). When 
you chose Apply To All, you will have a choice to apply this exact duration to all 
selected subpics, or to make sure they last at least that long, or at most that long.  
In the example below, the durations are adjusted to be at least 1.820 seconds 

 
 
 

 

2.10   If you have multiple sets of commands  

If you have multiple sets of commands (DCSQTs) use the drop-down selector to 
chose which one to modify before you apply any modification. At this point, the 
only data you can modify in DCSQTs other than the first one is the transparency. If 
you move the subpicture, only the first DCSQT is modified.   
 
 



3. Re-timing subtitles 
 

3.1   Changing the timing of a single subtitle 

In some rare cases, you need to move a subtitle from one location to another one, 
because this specific subtitle is out of sync with the video. 
To do that, make sure that you load the full title domain (by opening the files with 
the “Open Full Domain” menu, or making sure you’re dropping all the VOB files of 
the VTS in question – but excluding the menu of course, for example vts_01_0.vob).  
DVDSubEdit will refuse to re-time subpics if you’re in the menu domain, or if you 
omitted one of the vob files. Then click the “Retime this SPU” button. A small 
dialog will popup allowing you to specify either an absolute PTS (presentation time) 
where the subtitle should be displayed, or a value by which to move the subtitle. 
The PTS values are in seconds. In practice, it’s best to search for the target 
location of your subtitle using the preview before applying the move. Note the PTS 
of the image you’d like the subtitle to be synchronous with, and use this new PTS 
when you use the re-timing function. 
Because of the way DVDSubEdit works, if you need to move the subtitle by more 
than 3 to 5 seconds, it’s a good idea to do it in two steps, moving it first to an 
intermediate location then to the accurate target location. It’s also a good idea to 
check with a software player that the subtitle is displayed at the right time, and 
readjust if needed. 
Note that there is no undo for this operation. The vob files are modified as the 
operation completes, along with the corresponding IFO file. There is no need to 
subsequently save the subpics (they’ve already been saved). 
 

3.2   Re-timing all the subtitles 

In some cases, the entire subtitle track is out of sync with the video, either 
appearing too early or too late. DVDSubEdit lets you resynchronize the subtitles by 
moving them as a whole by a fixed positive or negative delay. Again, make sure you 
load the full domain and click the “Retime selected SPUs” button. A small dialog 
will popup where you can specify by how much the selected subtitles should be 
moved. Positive values (for example +1s) will make the subtitles appear later than 
they currently do. Negative values will make them appear before they currently do. 
Since this is a lengthy operation (requiring the modification of many packs in the 
vob files), it’s best to have a fairly good idea of how much the subtitles should be 
moved by.  
The operation takes more time when moving by a larger amount. Adding or 
subtracting a small delay (less than 1 second) is relatively fast, but moving by more 
than 3-4 seconds can become quite lengthy. 
Note that there is no undo for this operation. The vob files are modified as the 
operation completes, along with the corresponding IFO file. There is no need to 
subsequently save the subpics (they’ve already been saved). 
 



3.3   Re-timing issues 

Re-timing subtitles in place (i.e. directly inside the vob file, without 
demuxing/remuxing) is tricky. DVDSubEdit tries to do the best job it can, but you 
can still run into problems. 

• Subpicture collisions happen when one of the subpics you’re re-timing will 
end up in the same vobu as another one belonging to the same stream. 
While this isn’t illegal, it poses additional problems or subpicture ordering. 
For this reason, DVDSubEdit currently refuses to re-time a subtitle if it will 
collide with another one. You can run into that problem when re-timing an 
individual subtitle, and this is an indication that there’s already a subtitle 
that will be displayed around the same PTS. The solution is to make sure 
you’re not trying to display two subtitles at the same time. Sometimes, you 
will run into the problem when trying to move an entire subpicture track 
(for example if the track has a large number of subpics, close to each other, 
as in Spiderman R1 for example). 

• Angles:  Re-timing subtitles in multi-angle movies poses additional problems 
that DVDSubEdit isn’t currently able to handle. As a result, re-timing 
subtitles is forbidden in such cases. 
 

 

4. OCR (Optical Character Recognition) 
 
DVDSubEdit includes the GOCR code by Joerg Schulenburg, which works quite well 
on most subtitles (but not on all, unfortunately). OCR allows you to search subtitles 
for a specific word, or to filter your selection to only select subtitles that include 
one or several specific characters. This is convenient, for example, to select 
subtitles that include hearing-impaired text such as [footsteps] etc... 
 
To enable OCR-based functions, you’ll need to 
first run the OCR on the selected subpics by 
clicking the “Run OCR” button. This will run 
the OCR in the background. When this is done, 
you can use the search box to find occurrences 
of a word (case insensitive) in the selected 
subpictures  

 
 
In the Subpicture Selection area, you can type a 
set of characters (‘[‘ in the example on the 
right) and DVDSubEdit will only show subtitles 
that include any of these characters (case 
insensitive).   
This feature is useful for example to remove subtitles for the hearing impaired, 
which are usually enclosed between brackets “[“ or parentheses “(“. You can prune 
such subtitles using the OCR function, and quickly hide them if you don’t want 
them to appear in the final DVD. 
 



You can also export the output of the OCR as a text file by clicking the “Save OCR 
Output” button. This will save the subtitle text for each subtitle, including the 
stream ID, the sector of the first subpicture pack and the presentation time (PTS).  
 
The GOCR code works quite well on many subtitles, and does not require any 
preliminary “training”. However, it sometimes has problems with italicized text, 
and does not recognize some characters (such as music notes). 
Also note that DVDSubEdit does not try to run OCR on subpics that seem to contain 
button highlights (i.e., spus located in VOBUs where buttons are defined, and which 
are turned on by a forced start).  
 
 

5. Working with sup files and other topics 
 
DVDSubEdit lets you open and save .sup files. Sup files are created for example by 
VobEdit, or PgcDemux, and can be remuxed for example by using muxman.  
 
Loading: You can load a .sup file, either by drag/dropping it on the main dialog, or 
by using “Open .sup file” in the File menu. When working on a .sup file, no video is 
available (of course), and the CLUT is not available either. This means you will have 
to adjust the default CLUT so it looks good on your subpics, or check the “Auto 
CLUT” check box so the subpicture colors are adjusted to show the text (white for 
the character body, and black for all other pixels). In addition, you won’t be able 
to re-time subpics, or reload an individual spu. This being said, all other 
modifications are available, and can be saved back to a .sup file for later muxing 
into a vob. 
Saving: Whether you opened a VOB file or a sup file, you can save the selected spus 
as a .sup file, using the “Save selected spus as .sup file” in the “File” menu. Note 
that you must have selected a specific stream for this to work. The output file can 
then be used to remux the subpics into a new VOB, for example using the equally 
excellent freeware “muxman”. Note that DVDSubEdit does not keep track of 
discontinuous PTS. If the PTS resets at one point in the vob, the PTS associated with 
the spus after the reset point will also reset in the .sup file.   
 
DVDSubEdit also allows you to save the current subpicture as a ppm file using the 
“Save current spu as ppm” option in the “File” menu. This is useful to save a 
picture of the current subpicture. You can convert the .ppm file to any desired 
format using the very excellent freeware “IrfanView”. 
 

6. Appendices 
 

6.1   Keyboard shortcuts 

- Ctrl-0 Fast-reloads the last opened set of vobs. 
- Ctrl-S Saves modifications back to the vob files. 
- Ctrl-V Applies previous modifications to the current subpicture. 
- Ctrl-Z Reloads the current subpicture from file (undo changes) 
- Ctrl-A Applies previous modifications to all selected subpictures. 



- Ctrl-E Crop background of this subpicture. 
- Ctrl-T Runs the OCR on the currently viewed subtitle. 
- Ctrl-U Open a .sup file. 

 

6.2   Known problems and limitations 

- You can’t change subpicture positions in DCSQTs other than the first one. 
- You can’t change the delay of an individual DCSQT 
- The OCR code sometimes has problems with italics, and can fail to detect 

spaces between words. 
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